• Error

    From Paul Hayton@3:770/100 to All on Sat Apr 15 10:32:36 2017

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: FToolsW32.exe
    Application Version: 2.0.0.0
    Application Timestamp: 646e6148
    Fault Module Name: FToolsW32.exe
    Fault Module Version: 2.0.0.0
    Fault Module Timestamp: 646e6148
    Exception Code: c0000005
    Exception Offset: 00001597
    OS Version: 6.1.7601.2.1.0.256.48
    Locale ID: 5129
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e78

    Seeing this when running ftools addnew after moving from 1.7 to 2.0

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)
  • From Wilfred van Velzen@2:280/464 to Paul Hayton on Sat Apr 15 10:59:29 2017
    Hi Paul,

    On 2017-04-15 10:32:36, you wrote to All:

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: FToolsW32.exe
    Application Version: 2.0.0.0
    Application Timestamp: 646e6148
    Fault Module Name: FToolsW32.exe
    Fault Module Version: 2.0.0.0
    Fault Module Timestamp: 646e6148
    Exception Code: c0000005
    Exception Offset: 00001597
    OS Version: 6.1.7601.2.1.0.256.48
    Locale ID: 5129
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e78

    Seeing this when running ftools addnew after moving from 1.7 to 2.0

    I'm going to try and reproduce that...

    Bye, Wilfred.

    --- FMail-lnx64 2.1.0.7-B20170413
    * Origin: FMail development HQ (2:280/464)
  • From Paul Hayton@3:770/100 to Wilfred van Velzen on Sat Apr 15 21:20:58 2017
    On 04/15/17, Wilfred van Velzen pondered and said...

    I'm going to try and reproduce that...

    I moved back to the earlier version and it works fine again... I think!

    the tools program worked to do linking etc. it was when addnew was called
    that problems occurred

    This is on a windows 7 box 32 bit

    Best, Paul

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)
  • From Wilfred van Velzen@2:280/464 to Paul Hayton on Sat Apr 15 11:33:07 2017
    Hi Paul,

    On 2017-04-15 21:20:58, you wrote to me:

    I'm going to try and reproduce that...

    I moved back to the earlier version and it works fine again... I think!

    I don't think I tested that specific function after porting to the mingw compiler. So it is possible I overlooked something there.

    the tools program worked to do linking etc. it was when addnew was
    called that problems occurred

    This is on a windows 7 box 32 bit

    That shouldn't matter. ;)

    If I can't reproduce it on my system, I will get back to you for more details...

    Bye, Wilfred.

    --- FMail-lnx64 2.1.0.7-B20170413
    * Origin: FMail development HQ (2:280/464)
  • From Paul Hayton@3:770/100 to Wilfred van Velzen on Sat Apr 15 21:43:34 2017
    On 04/15/17, Wilfred van Velzen pondered and said...


    If I can't reproduce it on my system, I will get back to you for more details...

    OK no prob, glad to help :)

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)
  • From Wilfred van Velzen@2:280/464 to Paul Hayton on Mon Apr 17 23:18:12 2017
    Hi Paul,

    On 2017-04-15 21:43:34, you wrote to me:

    If I can't reproduce it on my system, I will get back to you for more
    details...

    I couldn't reproduce the crash. But I found an obvious bug in the 'addnew' function of ftools, that might explain the behaviour you experienced. A beta version of FToolsW32 with the fix is in your inbound.

    OK no prob, glad to help :)

    Thank you for testing and the bug report! ;)

    Bye, Wilfred.

    --- FMail-lnx64 2.1.0.7-B20170413
    * Origin: FMail development HQ (2:280/464)
  • From Paul Hayton@3:770/100 to Wilfred van Velzen on Tue Apr 18 15:01:53 2017
    On 04/17/17, Wilfred van Velzen pondered and said...

    I couldn't reproduce the crash. But I found an obvious bug in the
    'addnew' function of ftools, that might explain the behaviour you experienced. A beta version of FToolsW32 with the fix is in your inbound.

    Coolio, will try to plug it in tonight when I get home and test it out.

    Thank you for testing and the bug report! ;)

    Most welcome :)

    Best, Paul

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)
  • From Paul Hayton@3:770/100 to Wilfred van Velzen on Tue Apr 18 21:57:15 2017
    On 04/17/17, Wilfred van Velzen pondered and said...

    I couldn't reproduce the crash. But I found an obvious bug in the
    'addnew' function of ftools, that might explain the behaviour you experienced. A beta version of FToolsW32 with the fix is in your inbound.

    Installed and it run with Addnew

    [snip]

    FTools-W32-2.0.1.2-Beta20170417 - The Fast Message Base Utility

    Copyright (C) 1991-2017 by FMail Developers - All rights reserved

    DEBUG configPath: .\
    Areas added: 0, areas already present: 0

    AddNew Active: 0.016 sec.


    [snip]

    have also now re-installed the ver 2.0 for config and main exe and will see
    how we get on. Presume it's ok to mix / match those?

    Best, Paul

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)
  • From Wilfred van Velzen@2:280/464 to Paul Hayton on Tue Apr 18 13:01:20 2017
    Hi Paul,

    On 2017-04-18 21:57:15, you wrote to me:

    I couldn't reproduce the crash. But I found an obvious bug in the
    'addnew' function of ftools, that might explain the behaviour you
    experienced. A beta version of FToolsW32 with the fix is in your
    inbound.

    Installed and it run with Addnew

    [snip]

    FTools-W32-2.0.1.2-Beta20170417 - The Fast Message Base Utility

    Copyright (C) 1991-2017 by FMail Developers - All rights reserved

    DEBUG configPath: .\
    Areas added: 0, areas already present: 0

    AddNew Active: 0.016 sec.

    [snip]

    So it didn't crash, but there were no areas to add. I tested with 1 new area to
    be added. Did the crash happen when there were no areas to add?

    have also now re-installed the ver 2.0 for config and main exe and
    will see how we get on. Presume it's ok to mix / match those?

    It's ok, because the format of the config files didn't change. But it's better not to. ;)

    Bye, Wilfred.

    --- FMail-lnx64 2.1.0.7-B20170413
    * Origin: FMail development HQ (2:280/464)
  • From Paul Hayton@3:770/100 to Wilfred van Velzen on Wed Apr 19 12:19:32 2017
    On 04/18/17, Wilfred van Velzen pondered and said...

    So it didn't crash, but there were no areas to add. I tested with 1 new area to be added. Did the crash happen when there were no areas to add?

    Yes.

    It's ok, because the format of the config files didn't change. But it's better not to. ;)

    Yep figured I was on fairly safe ground :)

    Best, Paul

    --- Mystic BBS v1.12 A31 (Windows)
    * Origin: Agency BBS | telnet://agency.bbs.geek.nz (3:770/100)